You cannot select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
|
{
|
|
config,
|
|
lib,
|
|
pkgs,
|
|
...
|
|
}:
|
|
let
|
|
cfg = config.virtualisation.podman;
|
|
in
|
|
{
|
|
options.virtualisation.podman = {
|
|
compose.enable = lib.mkEnableOption "podman-compose";
|
|
};
|
|
config.environment.systemPackages = lib.mkIf (cfg.enable && cfg.compose.enable) [
|
|
pkgs.podman-compose
|
|
];
|
|
}
|